[rabbitmq-discuss] RabbitMQ install issue on Centos 5.5

Not Drew Stevens not.drew.stevens at gmail.com
Mon Mar 28 19:59:01 BST 2011

On 3/28/11 11:45 AM, Matthias Radestock wrote:
> Drew,
> On 28/03/11 19:14, Not Drew Stevens wrote:
>> I've been trying to get rabbitmq-server-2.4.0 up and running on Centos
>> 5.5 on an Amazon AWS instance.
>> My instance uses the following kernel:  2.6.18-xenU-ec2-v1.2
>> I've tried installation of erland and rabbitmq-server using:
>> 1) yum repos
>> 2) direct rpm installation
>> 3) compiling from source.
>> In every case, I get the following message when attempting to start the
>> RabbitMQ-Server process:
>> pthread/ethr_event.c:98: Fatal error in wait__(): Function not
>> implemented (38)
> We had a similar problem reported by a user last week. It looks like
> some compatibility issue with Erlang and certain custom Linux kernels.
> You say above that you tried compiling from source. Did that include
> Erlang? If so, what version did you try and did the compilation succeed?
> Regards,
> Matthias.

In all three cases, (repos, rpms and source compile) I installed Erlang
version R14B02.

The compilation was successfully. When I say successful, I mean that I
could start up the erlang console.  (I will admit that I did not try to
do anything very complicated in the console)

Maybe I'll try to install a previous version of Erlang to see if that
makes a difference.


More information about the rabbitmq-discuss mailing list