[rabbitmq-discuss] RabbitMQ install issue on Centos 5.5

Matthias Radestock matthias at rabbitmq.com
Mon Mar 28 19:45:27 BST 2011


On 28/03/11 19:14, Not Drew Stevens wrote:
> I've been trying to get rabbitmq-server-2.4.0 up and running on Centos
> 5.5 on an Amazon AWS instance.
> My instance uses the following kernel:  2.6.18-xenU-ec2-v1.2
> I've tried installation of erland and rabbitmq-server using:
> 1) yum repos
> 2) direct rpm installation
> 3) compiling from source.
> In every case, I get the following message when attempting to start the
> RabbitMQ-Server process:
> pthread/ethr_event.c:98: Fatal error in wait__(): Function not
> implemented (38)

We had a similar problem reported by a user last week. It looks like 
some compatibility issue with Erlang and certain custom Linux kernels.

You say above that you tried compiling from source. Did that include 
Erlang? If so, what version did you try and did the compilation succeed?



More information about the rabbitmq-discuss mailing list