[rabbitmq-discuss] Java Client not able to create channel

Abhishek Kona abhishek.kona at gmail.com
Thu Nov 25 11:56:52 GMT 2010

On 25/11/10 11:57 AM, Abhishek Kona wrote:
> On 24/11/10 5:50 PM, Abhishek Kona wrote:
>> On 24/11/10 5:28 PM, Abhishek Kona wrote:
>>> On 24/11/10 4:51 PM, Rob Harrop wrote:
>>>> That seems different to your previous report which mentioned that the
>>>> program waited at connection.createChannel() rather than
>>>> connectionfactory.newConnection(). Is that correct, or am I reading it
>>>> wrong :)
>>>> Can you create and post a thread dump of the process while it is 
>>>> waiting?
>>>> You can get one with jstack<pid>.
>>>> Regards,
>>>> Rob
>>>> On Wed, 24 Nov 2010 16:51:57 +0530, Abhishek Kona
>>>> <abhishek.kona at gmail.com>
>>>> wrote:
>>>>> On 24/11/10 4:29 PM, Rob Harrop wrote:
>>>>>> are seeing. I fixed this in the 2.1.1 client, so upgrading should do
>>>> the
>>>>> I have upgraded RabbitMQ and the client to 2.1.1 but still I see the
>>>>> same behavior.
>>>>> The application stops at
>>>>>               connection = connectionfactory.newConnection();
>>>>> It does not even fail and throw up.
>>>>> -Abhishek Kona
>>> Ya I was trying different things and this time I was creating a new 
>>> connection for each request, this time the block was at
>>> connection=connectionFactory.newConnection();
>>> I am attaching the jstack out put here,
>>> Thanks for the quick replies.
>>> -Abhishek Kona
>> I am able to confirm the same error,
>> My application stops at connection=connectionfactory.newConnection();
>> I am using RabbitMQ 2.1.1 and 2.1.1 Library.
>> I am attaching the jstack output again.
>> -Abhishek Kona
> Hi folks,
> Any opinions about the issue. My application only stops when I user 
> RabbitMQ, any first impressions?
> Thanks for all the fish.
> -Abhishek Kona
I am sorry for the trouble,
There was a RabbitMQ connection which was not being closed on an error.
This was causing many number of RabbitMQ connection threads being 
created, which was causing problems.

Also is there an issue with running RabbitMQ server on Mac? When I run 
the server on an Ubuntu Machine the above code was working.
I am not sure about this though, will report back if I face the same 
issue again.

Thanks a lot Rob for taking time to help me out.

-Abhishek Kona

More information about the rabbitmq-discuss mailing list