[rabbitmq-discuss] getting started, broker runs; can't get status

Matthias Radestock matthias at lshift.net
Thu Feb 5 09:52:29 GMT 2009


Matthias Radestock wrote:
> christopher hoover wrote:
>> It is a quoting problem.  I should have seen it before now.
>> The problem is that the new parameters are a glob:
>> ch at gato:/$ echo  [{nodelay,true},{sndbuf,16384},{recbuf,4096}]
>> a a a a [true,sndbuf,recbuf] [true,sndbuf,4096] [true,16384,recbuf]
>> [true,16384,4096]
>> I happen to have a directory named /a.   Billy, I would wager, happens to
>> have a directory name /t.
>> If I delete /a, it works with "cd /".
> Right. That's what I thought too when looking into the problem with 
> Billy. Putting single quotes around the term should stop the expansion. 
> However, when Billy tried that in the script he still got the same 
> problem. Does it work for you?

I've just tried this myself and I can reproduce Christopher's results. 
Moreover, putting single quotes around the terms in the rabbitmq-server 
script, i.e. changing the RABBITMQ_SERVER_ERL_ARGS settings to

true +A30 \
-kernel inet_default_listen_options 
'[{nodelay,true},{sndbuf,16384},{recbuf,4096}]' \
-kernel inet_default_connect_options '[{nodelay,true}]'"

does fix the problem for me. But when you tried the same earlier the 
problem remained. Could you please repeat that test?


More information about the rabbitmq-discuss mailing list