[rabbitmq-discuss] Running RabbitMQ as a Windows Service - Having some problems

Eran Sandler eran.sandler at gmail.com
Mon Sep 1 06:17:44 BST 2008

Hi Ben,

Thanks for the response.

The Erlang process goes up (it seems erlsrv when started takes the process
up) and I can telnet to port 5672 and get a response that contains the words
AQMP (which is usually the quickest way I check if the service is up), but
when I run "rabbitmqctrl status" it says the node is down.


On Mon, Sep 1, 2008 at 2:24 AM, Ben Hood <0x6e6562 at gmail.com> wrote:

> Eran,
> On Sun, Aug 31, 2008 at 8:48 PM, Eran Sandler <eran.sandler at gmail.com>
> wrote:
> > I've tried numerous ways of running RabbitMQ as a Windows service on
> Windows
> > 2003.
> >
> > I've used erlsrv.exe with the following command:
> >
> > erlsrv add rabbitmq_messagequeue -sname rabbit -args "-mnesia dir
> > '\"C:/RabbitMQ/db/rabbit-mnesia\"' -boot start_sasl -s rabbit -sasl
> > errlog_type error"
> >
> > The service runs but rabbitmq isn't running if I run "rabbitmqctrl.bat
> > status". I tried passing the rest of the arguments such as the log file
> > location etc but that makes the service not run.
> First of all, I have not run erlsrv myself because I don't have access
> to a windows machine, but I'm sure that this can achieved via VMware
> soon.
> However, I do know of somebody who has done this already with windows,
> so I've prompted them for the solution, hopefully that will turn up
> soon.
> BTW, to clarify your question - are you saying that Rabbit is actually
> running (meaning that you can connect to it via a client) and that the
> rabbitmqctrl.bat is just returning the wrong status when it is
> invoked?
> HTH,
> Ben
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080901/5c072ffa/attachment.htm 

More information about the rabbitmq-discuss mailing list