[rabbitmq-discuss] Running RabbitMQ as a Windows Service - Having some problems

Ben Hood 0x6e6562 at gmail.com
Mon Sep 1 00:24:02 BST 2008


On Sun, Aug 31, 2008 at 8:48 PM, Eran Sandler <eran.sandler at gmail.com> wrote:
> I've tried numerous ways of running RabbitMQ as a Windows service on Windows
> 2003.
> I've used erlsrv.exe with the following command:
> erlsrv add rabbitmq_messagequeue -sname rabbit -args "-mnesia dir
> '\"C:/RabbitMQ/db/rabbit-mnesia\"' -boot start_sasl -s rabbit -sasl
> errlog_type error"
> The service runs but rabbitmq isn't running if I run "rabbitmqctrl.bat
> status". I tried passing the rest of the arguments such as the log file
> location etc but that makes the service not run.

First of all, I have not run erlsrv myself because I don't have access
to a windows machine, but I'm sure that this can achieved via VMware

However, I do know of somebody who has done this already with windows,
so I've prompted them for the solution, hopefully that will turn up

BTW, to clarify your question - are you saying that Rabbit is actually
running (meaning that you can connect to it via a client) and that the
rabbitmqctrl.bat is just returning the wrong status when it is



More information about the rabbitmq-discuss mailing list