[rabbitmq-discuss] Broken 3 node cluster

Patrick Long pat at munkiisoft.com
Mon Mar 17 11:50:44 GMT 2014

RABBITMQ 3.2.1 on Windows Server 2003

Came into work this morning to find a suspected Network partition on a 3
node cluster

Node 3 and Node 2 said Node 1 was down

Node 1 said 2 and 3 were down

Tried stop_app on Node 1 but it hung stop_app on Nodes 2 and 3 were fine.

All 3 nodes hang on start_app

Tried restarting Windows service. Nodes 2 and 3 come back and are clustered

Node 1 will not start. In the end I removed all contents of the db
directory. Not it starts up.

I want to rejoin the cluster but it says it is already a member although
cluster_status says otherwise.

I have tried forget_cluster_node from one of the running nodes but that

Anyone any ideas?


Patrick Long - Munkiisoft Ltd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140317/bd666ec0/attachment.html>

More information about the rabbitmq-discuss mailing list