[rabbitmq-discuss] Federation chokes on load

Patrik Ring patrik.ring at bloglovin.com
Mon Mar 3 21:41:23 GMT 2014

Hi Rabbitmq-discuss,

We're currently trying to achieve a sync of our rabbit servers between two 
different data centers (one in Europe and one on US East coast). We're 
currently only in need of a one way sync (Europe -> US).

We thought setting up federation seemed like a good tool for this so we set 
it up and it worked like a charm when we were testing it internally with 
only developers. Then when starting to put load on it it just died. Some 
messages come through (but are heavily delayed, as in hours) but they seem 
completely random. We don't have any crazy number of messages being sent, 
it's just about a few 100 messages / second, and they aren't that big 

We do have quite a few bindings to the exchange we're federating (currently 
trying around 5000 simultaneously).

We have tried with both no-ack and on-confirm but doesn't seem to make a 

The message aren't routed to the queues on the receiver.

The error log is empty.
The web interface says everything is working
Small number of messages work, and the firewall is not blocking the 
traffic. Shouldn't be a network issue since we're on fairly good 
connections (>gbit) and have good internal networks that work well for 
everything else.



We might be using the wrong tool, in which case I'd be happy to know more, 
or we're just missing something. In which case I'd be really happy for some 
pointers and some help.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140303/b43375a9/attachment.html>

More information about the rabbitmq-discuss mailing list