[rabbitmq-discuss] rabbitmq-c TTL setting not working for me - please help

Kim Tran ktran0003 at gmail.com
Tue Jun 17 17:33:11 BST 2014

I tried to use the TTL attribute via management UI like this:
sudo rabbitmqctl set_policy TTL ".*" '{"message-ttl":4000}' --apply-to queue

And I still got all the messages. None of them was dropped.
The management UI shows for the queue:
Parameters | x-message-ttl: 2000
So my setting is recognized by the broker I guess.


On 6/16/2014 6:07 PM, Michael Klishin wrote:
> On 17 June 2014 at 05:03:54, ktran0003 at gmail.com (ktran0003 at gmail.com) wrote:
>>> Then every time I consume a message, I sleep for 5 secs just to
>> delay the consuming rate.
>> I also have the producer send a message every 1 sec.
>> However, when I run the producer to produce 20 messages, the consumer
>> will get all 20 messages with 5 sec delay in between.
>> Should some messages not delivered because of TTL < 5 sec delay?
> They should. Do you use the TTL attribute being set for queues in the management UI?
> --
> MK
> Software Engineer, Pivotal/RabbitMQ

More information about the rabbitmq-discuss mailing list