[rabbitmq-discuss] SSL upgrade error cacrtfile

Narayan Reddy bvnr.mail at gmail.com
Wed Jun 11 15:01:55 BST 2014

Thanks Simon, Michael, Matthias & RMQ team.

*sudo -s -u rabbitmq*
*bash-4.1$ cat /home/prime/SSL/testca/cert.pem*
*cat: /home/prime/SSL/testca/cert.pem: Permission denied*

Yes the error was due to permissions only, will correct it , Tried with
windows RMQ server it worked fine .. Thanks for the support RMQ team.

On 11 June 2014 15:08, Simon MacMullen <simon at rabbitmq.com> wrote:

> On 11/06/14 08:15, Narayan Reddy wrote:
>> Checked the permissions for the files, all permissions set to 777 for
>> ssl files. and change the owner of the files to active RMQ process user.
>> still facing the same error >
>> {options,{cacertfile,"/home/prime/SSL/testca/cacert.pem",{
>> error,eacces}}}}
> That "eaccess" really is telling you that the file cannot be read. Just
> because the permissions on the files are open doesn't mean the file can be
> read; intermediate directories must be readable too.
> I strongly recommend you become the rabbitmq user (with e.g. "sudo -s -u
> rabbitmq") and try to read the files. This should let you diagnose any
> problems.
> Cheers, Simon
> --
> Simon MacMullen
> RabbitMQ, Pivotal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140611/e3f159c2/attachment.html>

More information about the rabbitmq-discuss mailing list