[rabbitmq-discuss] Fedrating Queues not behaving as expected?

k.madnani84 k.madnani84 at gmail.com
Wed Feb 5 16:10:42 GMT 2014


I have 2 clusters Cluster1 and Cluster 2 each with two nodes.I am trying to
implement fedration queues wherein i am making my Cluster1 as downstream
cluster and cluster 2 as upstream cluster.I set a policy on cluster 1 such
that all the resources ending with ".federate" gets federated .Also i am
setting an Upstream parameter on cluster 1.
When i create a queue with name "myQueue.federate" a similar queue gets
created in Cluster 2 as well so that means the policy and parameter worked
fine and i could see in logs as :
Federation queue 'myQueue.federate' in vhost '/' connected to queue
'myQueue.federate' in vhost '/' on amqp://xxx.xxx.xxx.com:5672

So we are good till now.Next what i read is messages flow from Upstream to
downstream.That means in my case from Cluster2 to Cluster1.So i published
message in Cluster2 and tried to consume it from Cluster1 but i get a
response while consuming from Cluster1 that the queue is empty.

Also in RabbitMQ console for cluster2 i see 1 ready message in queue
myQueue.federate but for cluster1 i see 0 messages.

Could anybody tell me where am i wrong?

Thanks & Regards,

View this message in context: http://rabbitmq.1065348.n5.nabble.com/Fedrating-Queues-not-behaving-as-expected-tp33123.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list