[rabbitmq-discuss] Deleted Queues still showing in Management Plug-in

Ganann, Kale KGanann at kroll.com
Tue Oct 22 20:31:48 BST 2013

We had some issues with this approach - when we killed the final node it seemed to hose up the MNESIA db, and when we tried to reboot none of the nodes would come back fully - they either wouldn't start or wouldn't talk to each other.  I'd backed up the brokers and then spun up some new servers, which are working fine, but it wasn't a clean process getting there.  Any word on the timeline for that next release?


-----Original Message-----
From: Ganann, Kale 
Sent: Wednesday, October 16, 2013 10:48 AM
To: 'Simon MacMullen'; Discussions about RabbitMQ
Subject: RE: [rabbitmq-discuss] Deleted Queues still showing in Management Plug-in

Awesome, I'll try that.  Thanks for the info!


-----Original Message-----
From: Simon MacMullen [mailto:simon at rabbitmq.com]
Sent: Wednesday, October 16, 2013 10:45 AM
To: Discussions about RabbitMQ
Cc: Ganann, Kale
Subject: Re: [rabbitmq-discuss] Deleted Queues still showing in Management Plug-in

There is a known bug in HA which will be fixed in the next release which can cause behaviour like this (queue unresponsive in management and invisible in rabbitmqctl). It is triggered when you have a mirrored queue, and the master dies, and then the slave which would have been promoted to master dies before promotion can complete.

Does that sound like the sort of thing that could have happened? One way to make that happen without killing nodes on a precise timer is to switch from one ha-mode=nodes policy to another with minimal overlap.

I'm afraid the only work around at the moment is to stop the whole cluster and start it again. And the node which management claims has the master for this broken queue will hang at shutdown and need to be killed :-(

Cheers, Simon

On 16/10/13 16:28, Ganann, Kale wrote:
> Hey all,
> One of my Devs was trying to delete a queue through the management 
> plugin which got created on the wrong node, and asked me to help out.
> I went in and tried via the plugin, and it just hung, so I went 
> command-line on it and ran rabbitmqctl list_queues -p vhost.  When I 
> do that, that queue doesn't appear in the list.  Any ideas what might 
> be going on, and how I might be able to reconcile the two?  We're 
> running RabbitMQ 3.1.5 on SUSE 12.04.
> Thanks!
> Kale
> This communication contains information that is confidential, 
> proprietary in nature, and may also be attorney-client privileged 
> and/or work product privileged. It is for the exclusive use of the 
> intended recipient(s). If you are not the intended recipient(s) or the 
> person responsible for delivering it to the intended recipient(s), 
> please note that any form of dissemination, distribution or copying of 
> this communication is strictly prohibited and may be unlawful. If you 
> have received this communication in error, please immediately notify 
> the sender by replying to this message and delete this email 
> immediately. Thank you for your cooperation.
> Please be advised that neither Altegrity, its affiliates, its 
> employees or agents accept liability for any errors, omissions or 
> damages caused by delays of receipt or by any virus infection in this 
> message or its attachments, or which may otherwise arise as a result 
> of this e-mail transmission.
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

Simon MacMullen
RabbitMQ, Pivotal

More information about the rabbitmq-discuss mailing list