[rabbitmq-discuss] rabbitmq.config location when running as a Windows service

Gotthard, Petr Petr.Gotthard at Honeywell.com
Fri Oct 11 14:37:12 BST 2013


The trouble is that when I run in command-line 'rabbitmq-server start' then the config is found.
However, when I run the rabbitmq service in Windows, then the config is not found.


-----Original Message-----
From: Emile Joubert [mailto:emile at rabbitmq.com] 
Sent: 11. října 2013 15:26
To: Discussions about RabbitMQ
Cc: Gotthard, Petr
Subject: Re: [rabbitmq-discuss] rabbitmq.config location when running as a Windows service


On 11/10/13 12:52, Gotthard, Petr wrote:

> I have the rabbitmq.config in the directory as explained at 
> http://www.rabbitmq.com/relocate.html

The most common error is to create the file in the wrong directory, or forget the ".config" extension. The default location is %APPDATA%\RabbitMQ\rabbitmq.config

> But when I start the RabbitMQ service, the rabbitmq.config is silently 
> ignored. No warning nor error. Is this expected behavior?

This will happen if the config file is incorrectly named or in the wrong folder. A missing config file is not an error.


More information about the rabbitmq-discuss mailing list