[rabbitmq-discuss] lager vs sasl error log

Tim Watson tim at rabbitmq.com
Thu Mar 28 12:47:56 GMT 2013

Hi Guys,

Sorry for the delay - I've been chasing my tail this morning looking at what I thought was a bug, and thankfully I was wrong! :) 

So... I've just pushed a couple of fixes that should sort things out for you (Ben) I hope. The instructions in the README now specify that you should check out the git repository into a folder called 'lager' (regardless of the actual source repository name), the APPNAME variable has been reset to 'lager' and I've renamed the uploaded binary to 'lager-2.0.0.ez' - this should fix these issues for you. In the long term, if enough people really want to use lager then we'll probably come up with another (better) approach than this, but I just wanted to get folks going for the time being so we can get some feedback. 

Please do let me know if you get along better with this now. If you're building from source then do a `make clean` in the umbrella before attempting a rebuild (with the renamed rabbitmq-lager => lager directory freshly checked out) otherwise the build system will get all in a twizzy about dependencies.

As I said, we'll do this *properly* at some point soon (ish) and it won't be awkward like this when we release it into the wild.


On 28 Mar 2013, at 12:30, Ben Hood wrote:

> Hey Petr,
> I pulled the ez down with curl using the link specified in the README. I did this because it wouldn't build from source for me (see previous post), but that's probably because I just cloned Tim's repo into a subdir without renaming it. Having said that, I was just doing this quickly between flights, so I didn't really look into it too deeply.
> Cheers,
> Ben
> On Mar 28, 2013, at 7:48, "Gotthard, Petr" <Petr.Gotthard at Honeywell.com> wrote:
>> Ben,
>> Did you rename the .ez file? Because mine has an usual name that probably causes rabbit to crash (see my other post), but enabling works fine for me. Could you try using the .ez file with exactly the same name as created by the makefile?
>> Petr
>> From: rabbitmq-discuss-bounces at lists.rabbitmq.com [mailto:rabbitmq-discuss-bounces at lists.rabbitmq.com] On Behalf Of Ben Hood
>> Sent: 28. března 2013 3:21
>> To: Discussions about RabbitMQ
>> Subject: Re: [rabbitmq-discuss] lager vs sasl error log
>> Hey Tim,
>> On Wed, Mar 27, 2013 at 10:03 PM, Ben Hood <0x6e6562 at gmail.com> wrote:
>> I'm just kicking the tyres of your lager plugin with my rabbit umbrella.
>> Just to get things going, I tried using the published ez (md5: 9066ed797ca75519a68820271c79994a) but I ran into the following issue:
>> $ ./sbin/rabbitmq-plugins enable lager
>> Warning: Problem reading some plugins: [{"./sbin/../plugins/rabbitmq_lager-2.0.0.ez",
>>                                          {invalid_ez,bad_eocd}}]
>> Error: The following plugins could not be found:
>>   lager
>> Did I maybe grab the wrong thing?
>> Cheers,
>> Ben
>> _______________________________________________
>> rabbitmq-discuss mailing list
>> rabbitmq-discuss at lists.rabbitmq.com
>> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list