[rabbitmq-discuss] RabbitMQ 3.1.0 HTTP API rates are always zero

Darrell Burgan dburgan at peopleanswers.com
Sat Jun 1 23:20:19 BST 2013

First let me say I absolutely love RabbitMQ. Fabulous uptime and 
zero-headaches. I don't even worry about it every going down, it is so 
stable. An outstanding product.

I'm sure I'm doing something totally dumb, but I've tried everything I can 
think of and I am stumped. I am trying to use the HTTP API to do external 
monitoring of my RabbitMQ instances from Nagios. I discovered the HTTP API, 
which is awesome. The only trouble is that no matter what query I run via 
the HTTP API, the rates always come back as 0.0. For example:


This URL yields the following JSON:


Note that the rate is 0.0. This is on a production server that is processing between 100 and 1000 messages per second. Same for this URL:




I've verified that statistics are being gathered fine-grained.

Just for my own sanity management, I've attached a snippet of the management console from the same server that shows these rates are much higher than zero:


So I am stumped. I really want to run an HTTP API query that returns the "651" and "662" shown in the above image, but I cannot find it anywhere in the JSON the HTTP API returns. I have looked at the results for the following API calls to no avail:








Any suggestions?

Thanks so much in advance!

Darrell Burgan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130601/409d24a8/attachment.htm>

More information about the rabbitmq-discuss mailing list