[rabbitmq-discuss] Nagios Rabbitmq queue check plugin issue

Mr Mister incognito187 at live.co.uk
Wed Jul 24 17:45:16 BST 2013

i cannot get my queue checks to work, they all appear as critical with a 
status of null.

I am sure the issue is with my new nagios build, running a check manually 
throws a perl error (Can't locate Math/Calc/Units.pm in @INC... etc)

Ok so i though i need to install that module, its already installed, also 
installed other perl Math modules but none of the install Units.pm on to my 
server - i dont know how to get it installed, already tried reinstall 
including perl itself

However to add further confusion, i have an existing install which works, i 
am migrating to another location. I thought i could just grab the units.pm 
file and copy it to my new server, but the old one doesn't have this file 
either - yet if i run the same check manually i do not get the (Can't 
locate Math/Calc/Units.pm in @INC... etc) error.

Why do i need this module on my new install but not on the other, and more 
importantly why dont the checks work on my new install ?

i have investigated this issue for some time now but im stuck can anyone 
help ? i feel i need /usr/lib64/perl5/Math/Calc/Units.pm but cannot find it 

perl math modules i have installed are perl-Math-Calc-Units and 
perl-Math-Units , it sounds like it should be in the first one, 
documentation indicates it is in the second  - confused.

Im on latest CentOS using yum to install, the server is purely for Nagios 
and nagios only monitors rabbitmq.

Thanks for any help im offered.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130724/0bccc224/attachment.htm>

More information about the rabbitmq-discuss mailing list