[rabbitmq-discuss] beam.smp memory consumption keeps growing

Dennis Jacobfeuerborn djacobfeuerborn at gmail.com
Mon Jan 23 22:34:23 GMT 2012

Here is the new output (2.5mb):

It seems the memory issue has something to to with the clustering. When 
doing another test I saw in the management interface that the second node 
wasn't online (probably shut down by a co-worker). I ran the script with 
just the one node and after the message where consumed all the memory was 
returned properly. So I started the second node and tried again. This time 
the memory wasn't returned at the end on the first node but on the second 
one it was. Then I shut down the second node again and shortly after that 
the first node went back to almost the initial memory consumption level.
The new dump shows the state when both cluster nodes are online and the 
second node has returned its memory but the first one hasn't. The command 
was run on the first node.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120123/02e034a5/attachment.htm>

More information about the rabbitmq-discuss mailing list