[rabbitmq-discuss] rabbitmq-plugins not working as root user

Tommy Odom tommy.odom at gmail.com
Thu Dec 20 16:49:37 GMT 2012

Hi all,

Just installed rabbitmq-server on Ubuntu 12.04 using the latest 3.0.1 
package and I am running into a problem running the rabbitmq-plugins 
list/enable commands.  I have 3.0.0 installed on a separate server as well 
and it seems to be working correctly for me.  

When I run "sudo rabbitmq-plugins list" I get an error "Failed to create 
cookie file".  I looked at the /usr/sbin/rabbitmq-plugins script and I see 
that it has some logic for determining when to su over to the rabbitmq user 
so I tried explicitly running "sudo su rabbitmq -s /bin/sh -c 
"/usr/lib/rabbitmq/bin/rabbitmq-plugins list" and that worked correctly. 
 The rabbitmq-server is running and the /var/lib/rabbitmq directory is 
owned by rabbitmq user and does have a .erlang.cookie file present.

However, when I try to run rabbitmq-plugins as the rabbitmq user to enable 
a plugin I get an error that it can't write the 
/etc/rabbitmq/enabled_plugins file because the /etc/rabbitmq directory is 
owned by root.

I verified that on my 3.0.0 server I am able to run "sudo 
/usr/lib/rabbitmq/bin/rabbitmq-plugins list" directly w/o the su to the 
rabbitmq user.

Any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20121220/eef47626/attachment.htm>

More information about the rabbitmq-discuss mailing list