[rabbitmq-discuss] RabbitMQ consumer stops receiving messages

Maxime Bouroumeau-Fuseau maxime.bouroumeau at gmail.com
Tue Jul 19 09:46:45 BST 2011


I have a serious problem with RabbitMQ. After a certain amount of messages
received, the consumers simply stop receiving messages.
They are still connected but they are not receiving messages anymore. I have
found other posts about this issue but none have a working answer.

Here is the connection wrapper I use: http://pastebin.com/XVY3HNGq. I use
stormed-amqp which is an async amqp lib for python.

All errors are caught and none are thrown during the process and I'm pretty
sure it doesn't come from an application error (but I can be mistaken of
course :).
On the same server there is a single exchange with 2 queues which each
process hundreds of thousands of messages a day. The first queue (which
works just fine) receives messages,
processes them and publishes them in the second one for further processing.
It's this second queue which stops after a certain amount of messages. I
have tried with one or multiple consumers
but the problem remains.

I have tried consuming messages without ack or with ack and a qos prefetch
count of 100 (as indicated in several responses to this kind of problems).
When I do "rabbitmqctl list_queues name messages_ready
messages_unacknowledged", I have a lot of ready messages and the "prefetch
count" (100) value of unacknoledged messages when using ack.

I really don't know wha'ts happening!
Thank you for your answers.

Maxime Bouroumeau-Fuseau
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110719/ff446313/attachment.htm>

More information about the rabbitmq-discuss mailing list