[rabbitmq-discuss] Problem after upgrading to 2.3.1

mysurf mail stammailbox at gmail.com
Sun Feb 27 11:06:41 GMT 2011

Well, its ok to ask dumb questions, I am afraid I did something dumb and
didnt find it out yet...

Anyway, yes I did.
I upgraded the server, upgraded the two application (java apps).
(BTW - in the clients server there is no erlang. erlan is installed only in
the rabbitMQ server only )
when I put all the exe's (using exe4j for java )  in my dev computer -
everthing works as designed.
I copy one exe to the production server and I get the SocketExceptio out of

should I install erlang in the clients server also?

everuthing works great with 1.7.0 and no new port or IP was added (So it is
not firewall)

On Sun, Feb 27, 2011 at 12:40 PM, Matthew Sackman <matthew at rabbitmq.com>wrote:

> On Sun, Feb 27, 2011 at 11:54:49AM +0200, mysurf mail wrote:
> > Well, it seemed fine when I tried to do it all in my local computer (two
> > apps and rabbit)
> > but when I upgraded the clients in the production environment (whoops)
> the
> > clients threw the following exception:
> > (side note: I did not change any property (socket,port etc ) in the
> client
> > side. so i am guessing firewall is not an option because everything
> worked
> > with the former version of rabbit - 1.7.0.  )
> This is likely a dumb question, but could you just confirm whether or
> not you upgraded the server at the same time? Client versions >= 2.0.0
> will not talk (normally - the .Net client can be made to) happily to
> versions of the broker < 2.0.0.
> Matthew
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110227/ee4208c7/attachment.htm>

More information about the rabbitmq-discuss mailing list