[rabbitmq-discuss] Problems starting RabbitMQ as a windows service.

Emile Joubert emile at rabbitmq.com
Mon Aug 15 13:46:53 BST 2011

Hi Richard,

On 15/08/11 00:26, Richard Hudson wrote:

> Having looked though the archives we've tried passing in sname and name
> arguments to erl.exe with no luck.

So do you get the same error when you run this command:
 erl -sname foo
Does it still fail if you use the erl.exe from the erts-5.8.4\bin directory?

> Does anyone have any thoughts on why the standard service install would
> fail but the application and modified install seem to work fine.

The security context is different. Confirm that the system account
running the service has network permissions.

I've also seen this happen in the presence of an SSL configuration. Do
you have a rabbit config file?

> How safe is it to use erl.exe from erl5.8.4\bin\erl.exe rather than
> erl5.8.4\erts-5.8.4\bin\erl.exe? i.e is this an acceptable workaround.

This is an interesting clue about the problem. It would be safer to
understand the underlying cause than to rely on this workaround in a
production environment.

Do you get the error with previous versions of rabbit? Rabbit v2.2.0
would be a useful candidate if the problem is related to  IPv6.


More information about the rabbitmq-discuss mailing list