[rabbitmq-discuss] Cluster size limit

Matthew Sackman matthew at rabbitmq.com
Wed Apr 6 15:48:10 BST 2011

On Sun, Apr 03, 2011 at 05:28:44PM +0530, Advait Alai wrote:
> I am not sure why this error still appears after I attempt 'rabbitmqctl
> start_app'. I tried disk clustering as well, with the same result. The error
> logs look like this:
> rabbit at node117.log:  http://pastebin.com/embhVaea
> rabbit at node117.log.1: http://pastebin.com/Xa5ZnWrC
> rabbit at node117-sasl.log: (empty)
> rabbit at node117-sasl.log.1: http://pastebin.com/Au745uNU
> node117 is the proxy node, with which I cluster all other 99 nodes (as
> either disc or ram nodes). This seems to be the error (from the logs):
> exception exit: {{badmatch,
>                          {error,
>                              {file_error,
>                                  "/var/lib/rabbitmq/mnesia/rabbit at node117
> /msg_store_transient/file_summary.ets",
>                                  enoent}}},

Hmm, curious. I don't see why that should be happening. You are issuing
the reset command on each node after stop_app and before cluster, yes?


More information about the rabbitmq-discuss mailing list