[rabbitmq-discuss] Mgmt plugin (2.1.1)

Alext0 althomas at maninvestments.com
Fri Oct 22 14:16:34 BST 2010

Unfortunately the R14B from http://repos.fedorapeople.org/ doesn't seem to be
there yet.

I've tried a couple of other things:

1) Built from src, but startup fails even with no plugins:
Activating RabbitMQ plugins ...
ERROR: generation of boot script file
/opt/mnesia/flopsy/plugins-scratch/rabbit.script failed:

2) Tried a branch of Mochiweb that is R12B compatible from
Strangely, this referenced boolean(), which apparently is after Erlang R12,
so I changed this to bool(). 
This still didn't build correctly though - see below - so maybe I haven't
picked up the right branch.

[athomas at tlonapesbs52 mochiwebR12B]$ make
(cd src;make all)
make[1]: Entering directory `/home/athomas/projects/mochiwebR12B/src'
../support/make_app.escript mochiweb.app.src ../ebin/mochiweb.app _
"mochifmt mochifmt_records mochifmt_std mochiglobal mochihex mochijson2\
 mochijson mochilists mochilogfile2 mochinum mochitemp mochiutf8
mochiweb_acceptor mochiweb_app mochiweb_charref mochiweb_cookies mochiweb_\
cover mochiweb_echo mochiweb mochiweb_headers mochiweb_html mochiweb_http
mochiweb_io mochiweb_mime mochiweb_multipart mochiweb_request moc\
hiweb_response mochiweb_skel mochiweb_socket mochiweb_socket_server
mochiweb_sup mochiweb_util reloader"
escript: exception error: undefined function erl_scan:string/3
make[1]: *** [../ebin/mochiweb.app] Error 127
make[1]: Leaving directory `/home/athomas/projects/mochiwebR12B/src'
make: *** [all] Error 2

Any other tips appreciated


Alext0 wrote:
> Crikey, low latency email! Thank you both...
> Yes this is with R12B5, and explains why Mochiweb is missing erlang:max. 
> I haven't been able to get R14B yet but will try that.
> cheers
> Alex
> Simon MacMullen-2 wrote:
>> On 21/10/10 16:56, Alext0 wrote:
>>> Hi folks,
>>> Can anyone confirm whether the latest mgmt plugin works on 2.1.1?
>> Certainly should do.
>>> Just doing a fresh install on Linux and we see a crash from
>>> rabbit_mochiweb:
>>>      application: rabbit_mochiweb
>>>      exited: {shutdown,{rabbit_mochiweb_app,start,[normal,[]]}}
>>>      type: permanent
>>> I thought we might be tempting fate running on RHEL 5.0 rather than 5.5
>>> but
>>> from what I understand this error usually indicates an app-level
>>> problem.
>> Which Erlang? Mochiweb unfortunately needs a newer one than the R12B5 in 
>> EPEL (yes, this is going to be documented better).
>> I noticed today that http://repos.fedorapeople.org/ claims to have an 
>> RPM for R14B that is compatible with EPEL 5 / EPEL 6.
>> Cheers, Simon
>> -- 
>> Simon MacMullen
>> Staff Engineer, RabbitMQ
>> SpringSource, a division of VMware
>> _______________________________________________
>> rabbitmq-discuss mailing list
>> rabbitmq-discuss at lists.rabbitmq.com
>> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

View this message in context: http://old.nabble.com/Mgmt-plugin-%282.1.1%29-tp30020890p30028590.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list