[rabbitmq-discuss] rabbitmq beginner, cannot start rabbitmq/cannot get status

Matt Long mlong at crocodoc.com
Thu Oct 14 21:33:03 BST 2010


I've just started using rabbitmq. I've run into trouble trying to use
rabbitmq-server on an Ubuntu 10.04 EC2 EBS instance (ami-6006f309). When I
first installed rabbitmq (sudo apt-get install rabbitmq-server), it was
working just fine and also worked fine after stopping/starting my EC2
instance. However, now after I reboot the EC2 instance and ssh back in, I
get this when trying to check the status (the first command I issue):

$ sudo rabbitmqctl status
Status of node 'rabbit at ip-10-100-100-200' ...
Error: unable to connect to node 'rabbit at ip-10-100-100-200': nodedown
- unable to connect to epmd on ip-10-100-100-200: address
- current node: 'rabbitmqctl812 at ip-10-100-100-200'
- current node home dir: /var/lib/rabbitmq
- current node cookie hash: X5WdGfO9GimAgcVGJx/dSQ==

So then I try to manually start it:

$ sudo rabbitmq-server
{error_logger,{{2010,10,14},{19,54,3}},"Protocol: ~p: register error:
{"Kernel pid

Crash dump was written to: erl_crash.dump
Kernel pid terminated (application_controller)

>From googling around I determined that that error means rabbitmq is already
running, which makes sense since it should have started via /etc/init.d. So
I kill the running processes and then try to start it again and it appears
to startup fine:

$ ps ax | grep beam
  530 ?        Sl     0:00 /usr/lib/erlang/erts-5.7.4/bin/beam.smp -- -root
/usr/lib/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa
/usr/lib/rabbitmq/lib/rabbitmq_server-1.7.2/sbin/../ebin -noshell -noinput
-hidden -sname rabbitmq_multi530 -s rabbit_multi -extra start_all 1
  661 ?        Ssl    0:00 /usr/lib/erlang/erts-5.7.4/bin/beam.smp -W w -K
true -A30 -- -root /usr/lib/erlang -progname erl -- -home /var/lib/rabbitmq
-- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-1.7.2/sbin/../ebin -noshell
-noinput -s rabbit -sname rabbit -boot start_sasl -kernel
inet_default_listen_options [{nodelay,true}] -kernel
inet_default_connect_options [{nodelay,true}] -sasl errlog_type error
-kernel error_logger {file,"/var/log/rabbitmq/rabbit.log"} -sasl
sasl_error_logger {file,"/var/log/rabbitmq/rabbit-sasl.log"} -os_mon
start_cpu_sup true -os_mon start_disksup false -os_mon start_memsup false
-mnesia dir "/var/lib/rabbitmq/mnesia/rabbit" -noshell -noinput
  972 pts/0    R+     0:00 grep --color=auto beam
$ sudo kill 530
kill: No such process
$ sudo kill 661
$ sudo rabbitmq-server
*<standard rabbitmq logo and other info>*
node          : rabbit at ip-10-100-100-200
app descriptor:
home dir      : /var/lib/rabbitmq
cookie hash   : X5WdGfO9GimAgcVGJx/dSQ==
log           : /var/log/rabbitmq/rabbit.log
sasl log      : /var/log/rabbitmq/rabbit-sasl.log
database dir  : /var/lib/rabbitmq/mnesia/rabbit
*<alot of "starting" lines; each of which has "...done" at the end>*
broker running

Then in another SSH terminal I try to check the status and get the same
error as my first attempt to check the status. So I again made no rabbitmq
(i.e. beam) processes were running and tried to start rabbitmq via

$ sudo /etc/init.d/rabbitmq-server start
Starting rabbitmq-server:
*<indefinite hang, had to Ctrl-C,Ctrl-C>*

I tried several other things like deleting all contents of /var/lib/rabbitmq
and that starting again; all to no avail. Can someone help? I'm hoping this
is fairly easy to reproduce as I did a very straightforward setup from the
official Ubuntu us-east ebs ami (ami-6006f309). Note that I've changed the
hostname (ip-10-100-100-200) in everything I've pasted above from it's
original (but similar) value for privacy.

Also, at some point in my testing i got the following in startup_err, but I
can't remember what the steps were that led to getting that error message:

$ cat /var/log/rabbitma/startup_err
Error: cannot_get_pid

Many thanks in advance for any help!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20101014/d9bfd9d6/attachment-0001.htm>

More information about the rabbitmq-discuss mailing list