[rabbitmq-discuss] Data may be missing, Corrupt logfile deleted

john_od john.odendahl at gmail.com
Tue Jan 19 21:44:45 GMT 2010

My rabbitmq keeps erroring with the following message:

Mnesia('rabbit at hostname'): Data may be missing, Corrupt logfile deleted:

Once this occurs I cannot connect to the queues.  Nor can i run a simple
rabbitctl list_queues.  The following error is produced from rabbitmqctl:

root at hostname:/usr/local/rabbitmq_server-1.7.0/sbin# ./rabbitmqctl
Listing queues ...
Error: unable to connect to node 'rabbit at hostname':
- nodes and their ports on hostname: [{rabbit,45971},
- current node: 'rabbitmqctl23146 at hostname'
- current node home dir: /root

I've tried removeing the /var/lib/rabbitmq directory as well as the
Once i do this the broker runs ok for a short period of time but then it
errors again.
Disk space does not seem to be a problem. 
I am running the 1.7.0 server in a solaris environment.

Any ideas?

View this message in context: http://old.nabble.com/Data-may-be-missing%2C-Corrupt-logfile-deleted-tp27233256p27233256.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list