[rabbitmq-discuss] Unable to store messages into queue

Dinh pcdinh at gmail.com
Tue Dec 14 04:08:50 GMT 2010

Hi all,

I got a strange situation with RabbitMQ 2.1.1, Mac OSX 10.6.5, erlang
version : (not sure if it is a bug): I was unable to store message
into queue using Python clients.In fact, it is standard code I took from
RabbitMQ site. So it is supposed to work. It already worked before. For me,

import pika

import sys

import pickle

import json

connection = pika.AsyncoreConnection(pika.ConnectionParameters(


        credentials=pika.PlainCredentials('guest', 'guest')))

channel = connection.channel()

channel.queue_declare(queue='feeds', durable=True)

message = json.dumps({"import_feed": "http://cnn.com/rss/edition.rss"})

channel.basic_publish(exchange='', routing_key='importer',



                         delivery_mode = 2, # make message persistent


print " [x] Sent %r" % (message,)

After running these code for several time, I checked with RabbitMQ to see if
those message were stored in the queue

Dinh-Phams-MacBook-Pro:~ dinhpham$ sudo
/Users/dinhpham/dev/rabbitmq_server-2.1.1/sbin/rabbitmqctl list_queues name
messages_ready messages_unacknowledged
Listing queues ...
feeds 0 0

It meant that "feed" queue is created but no message is stored.

In fact, those code worked in the past. It suddenly refused to work after I
had sent several hundred thousands of messages into the queue and deleted
them all for new tests. After several deletion, RabbitMQ refused to work
with the code. No message was stored or no queue was created at all
(happened with Carrot Python client)

Anybody has experienced this case? Is there any log that I can look into to
see what happened?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20101214/7602fd20/attachment-0001.htm>

More information about the rabbitmq-discuss mailing list