[rabbitmq-discuss] Can't run rabbitmq-server... Install issue?

Squeegy alex at beautifulpixel.com
Tue Oct 20 02:24:16 BST 2009

I seem to have quite an adventure getting rabbitmq-server running on my snow
leopard machine.

Macports failed to install erlang, due to some bizarre compilation errors,
so I installed it from source.  It also failed to install rabbitmq-server,
so I tried to install it manually.  I it appears to have install erlangs
libs to /usr/local/lib/erlang/lib/, so that it where I put the
rabbitmq-server-1.7.0 directory.  But when I run the server, it's not happy:

$ /usr/local/lib/erlang/lib/rabbitmq-server-1.7.0/scripts/rabbitmq-server
{"init terminating in

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()

The crash log is no less than 12,000 lines and I have no idea what to make
of it.  I can run "erl" just fine, and I get the erlang prompt (I think):

$ erl
Erlang R13B02 (erts-5.7.3) [source] [smp:2:2] [rq:2] [async-threads:0]

Eshell V5.7.3  (abort with ^G)

So I have no idea what is going on here.  I have put the crashdump up here:

In case someone  smarter than I can make heads or tails of it.  I would
really appreciate any tips here and what noobie mistake I made here.

Thank you to anyone who can help me out.
View this message in context: http://www.nabble.com/Can%27t-run-rabbitmq-server...-Install-issue--tp25967988p25967988.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list