[rabbitmq-discuss] mochiweb plugin

Ben Browitt ben.browitt at gmail.com
Mon Oct 19 09:32:47 BST 2009

On Mon, Oct 19, 2009 at 10:24 AM, Paul Jones <pauljones23 at gmail.com> wrote:

> Ben,
> On Mon, Oct 19, 2009 at 9:08 AM, Ben Browitt <ben.browitt at gmail.com>wrote:
>> If mochiweb.ez should be installed in the plugin directory it will help if
>> you can document it or even better create two plugins, rabbitmq-mochiweb for
>> the wrapper and mochiweb for mochiweb itself.
>> When I run make in the rabbitmq-mochiweb folder I saw that mochiweb is
>> being downloaded and compiled automatically so I thought the plugin is
>> taking care of everything for me.
> I'm getting the documentation updated to make this clearer. We wanted to
> avoid actually including mochiweb into the plugin, as bundling external
> dependencies could quickly lead to naming clashes if taken up as a standard
> pattern.
>> Can you explain more about the process that you're following to get the
>>> error you report? The plugin activation process itself shouldn't cause
>>> applications to be started - I'm assuming you're seeing this error when
>>> booting rabbit after installing the plugins?
>> Yes, I'm getting the error when running rabbit after compiling, linking
>> and activating the plugins.
>> I've created the umbrella project
>> compiled the rabbitmq-mochiweb, erlang-rfc4627 and rabbitmq-jsonrpc
>> plugins
>> linked the three plugins to the rabbitmq-server/plugins directory
>> run the scripts/rabbitmq-activate-plugins script
>> rabbitmq-server/make run
> I've followed this exact set of steps, and the server is starting cleanly
> for me. My plugin directory symlinks look like:
> erlang-rfc4627 -> ../../erlang-rfc4627/
> mochiweb -> ../../rabbitmq-mochiweb/deps/mochiweb
> rabbitmq-jsonrpc -> ../../rabbitmq-jsonrpc
> rabbitmq-mochiweb -> ../../rabbitmq-mochiweb

I've repeated all the steps and still getting the error.
It happens when jsonrpc tries to use rabbit_mochiweb_registry. Erlang
complains that the proc is not registered.

> As an aside, if you're wanting the functionality previously provided by
> rabbitmq-http2, then you'll also want to link in the
> rabbitmq-jsonrpc-channel plugin - this plugin provides the actual support
> for making JSON-RPC calls against the rabbit channel objects.

I know. I'm trying to create a plugin that uses the mochiweb plugin but got
errors so I've tried using the jsonrpc
plugin as a reference but got the same errors.

I'll try to remove the umbrella folder and repeat all the steps.

There is also a bug in the rabbit_metronome hello-word example
at http://www.rabbitmq.com/plugin-development.html#getting-started
rabbit_metronome_worker/init calls amqp_connection:start_direct(<<"guest">>,
but there is no amqp_connection:start_direct/2.  I think it should be
amqp_connetion:start_direct() because guest is the default.

> Paul.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20091019/8daf9a1a/attachment.htm 

More information about the rabbitmq-discuss mailing list