[rabbitmq-discuss] Does erlang client tip work with server tip?

Keith Irwin keith.irwin at gmail.com
Sun May 17 22:31:42 BST 2009

I tried this again using the generic unix release (1.5.4), setting
appropriate environment vars such that I can start RabbitMQ using
rabbit-server, and, again, the server seems to start up fine,
indicating "broker running".

I did a fresh checkout of rabbitmq-erlang-client, used

   make BROKER_DIR=../rabbitmq_server-1.5.4/

which worked fine.


  make test_network

and I get:

erl -pa ebin rabbitmq_server/ebin -noshell -eval
network_client_test: basic_get_test...*timed out*
  Failed: 0.  Skipped: 0.  Passed: 0.
One or more tests were cancelled.

On the server side, I see:

=INFO REPORT==== 17-May-2009::14:24:54 ===
accepted TCP connection on from

=INFO REPORT==== 17-May-2009::14:24:54 ===
starting TCP connection <0.221.0> from

=ERROR REPORT==== 17-May-2009::14:24:59 ===
error on TCP connection <0.221.0> from

=INFO REPORT==== 17-May-2009::14:24:59 ===
closing TCP connection <0.221.0> from

Puzzling. I'm not sure if this means the erlang client is basically
broken, or there's some magic config somewhere. I guess the next step
is to try and write a client using the erlang-client code and see if
there's anything to be seen. Then to write one in Groovy (using the
java client) to see if that works.

(I'm wishing you didn't have to have rabbitmq_server even installed to
get an erlang_client, just for these sorts of reasons.)

Anyway, it would help if anyone could even tell me that this is
supposed to work! I'd be happy to struggle, as long as I've chosen the
right road to go down....


On Sun, May 17, 2009 at 12:57 PM, Keith Irwin <keith.irwin at gmail.com> wrote:
> Folks--
> Basic problem: Can't get the erlang-client network tests to succeed,
> using the HG tips of rabbitmq_server and rabbitmg_erlang_client.
> Error is:
> erl -pa ebin rabbitmq_server/ebin -noshell -eval
> 'network_client_test:test(),halt().'
> network_client_test: basic_qos_test...*timed out*
> undefined
> =======================================================
>  Failed: 0.  Skipped: 0.  Passed: 2.
> One or more tests were cancelled.
> Just starting to experiment with rabbitmq. I'm mostly interested in
> how to run it in a sandbox as opposed to "properly" installing it in
> /opt/local/bin (MaxOS) or other such system areas.
> The goal is to cd into rabbitmq, start it up, then in a separate
> shell, cd into some client code (yet to be written), and start that
> up, and watch things happen.
> (As a comparison, ActiveMQ can run straight from the untarred
> download, if you want.)
> So, here's what I did:
>  cd Rabbits
>  hg clone http://hg.rabbitmq.com/rabbitmq-server
>  hg clone http://hg.rabbitmq.com/rabbitmq-codegen
>  cd rabbitmq-server
>  make
>  cd ebin
>  erl -boot start_sasl -s rabbit
> and as far as I can tell, the app starts up just fine. I even tried
> appmon:start() to see all the processes and applications. Looks good
> to me!
> Then:
>  cd Rabbits
>  hg clone http://hg.rabbitmq.com/rabbitmq-erlang-client/
>  make
>  make test_network
> and I get the error:
>  erl -pa ebin rabbitmq_server/ebin -noshell -eval
> 'network_client_test:test(),halt().'
>  network_client_test: basic_qos_test...*timed out*
>  undefined
>  =======================================================
>    Failed: 0.  Skipped: 0.  Passed: 2.
>  One or more tests were cancelled.
> I'm using the recent MacPorts version of Erlang (13B with fixed Eunit
> installed).
> I guess the first question is, does the tip of the erlang client code
> work with the tip of the erlang rabbitmq code?
> If so, is it possible to run rabbitmq server straight from the ebin
> directory, as I've done above?  (I'm not so concerned at the moment
> about a distributed set up).
> Thanks!
> Keith

More information about the rabbitmq-discuss mailing list