[rabbitmq-discuss] Erlang client handshake problem

Dave Bryson daveb at miceda.org
Wed Jan 28 01:09:41 GMT 2009

Possible reason:

It looks like that by default "amqp_connection:start()" uses the  
"amqp_direct_driver"  See line 50 in the amqp_connection.erl.  Which  
assumes your running the client in the same process as the server.   
The connection type is also used by the "network_client_test".  Is  
this correct?  This could possible explain the error I'm getting.


On Jan 27, 2009, at 4:35 PM, Ben Hood wrote:

> Dave,
> On Tue, Jan 27, 2009 at 2:02 PM, Dave Bryson <daveb at miceda.org> wrote:
>> I have not been able to get the Erlang client to connect to the
>> server. I've tried connecting to both the local server and the
>> rabbitmq public server and getting the same problem on
>> both...basically the client just hangs trying to make the connection.
>> This happens when I run the network_test as well.   Looking in my
>> local server log I keep seeing the same errors over and over:
> Can we have a few more clues about your setup, e.g. which specific
> version of the client you are running and how you are running it?
> Ben

More information about the rabbitmq-discuss mailing list