[rabbitmq-discuss] rabbitmqctl crashes in vista

Emile Joubert emile at lshift.net
Fri Nov 7 12:43:24 GMT 2008

Hi Gavin,

The rabbitmqctl.bat script assumes that the current working directory is 
"sbin". The problem you reported should be solved if you set the current 
directory of the command shell to the sbin subdirectory of the main 
rabbit server directory before running.


Gavin Bong wrote:
> Rabbit is installed in a separate directory
> e.g. c:\_programs\rabbitmq-etc...
> Erlang is installed in its own directory.
> I set the ERLANG_HOME
> I added the path to the sbin directory of the rabbitmq installation.
> Then I run the rabbitmqctl command.
> That's it. Nothing else.
> 2008/11/7 Ben Hood <0x6e6562 at gmail.com>:
>> Gavin,
>> On Fri, Nov 7, 2008 at 9:19 AM, Gavin Bong <vinorasmus at gmail.com> wrote:
>>> I started the broker and I encountered core dumps when trying to run
>>> the rabbitmqctl command. Why is this so ?
>>> C:\Users\gavin>echo %ERLANG_HOME%
>>> C:\_programs\erl5.5.5
>>> C:\Users\gavin>rabbitmqctl status
>>> {"init terminating in do_boot",{undef,[{rabbit_control,start,[]},{init,start_it,
>>> 1},{init,start_em,1}]}}
>> That looks like it can't find the binaries for the the rabbit_control module.
>> Can you elaborate on how you set Rabbit up please?
>> Ben
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> http://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list