[rabbitmq-discuss] Running RabbitMQ as a Windows Service - Having some problems

Eran Sandler eran.sandler at gmail.com
Sun Aug 31 20:48:24 BST 2008

Hello all,

First time on the mailing list :-) I think RabbitMQ is great but I have
a small problem running it as a Windows service.

I've tried numerous ways of running RabbitMQ as a Windows service on
Windows 2003.

I've used erlsrv.exe with the following command:

erlsrv add rabbitmq_messagequeue -sname rabbit -args "-mnesia dir
'\"C:/RabbitMQ/db/rabbit-mnesia\"' -boot start_sasl -s rabbit -sasl
errlog_type error"

The service runs but rabbitmq isn't running if I run "rabbitmqctrl.bat
status". I tried passing the rest of the arguments such as the log file
location etc but that makes the service not run.

Any ideas?

Thanks in advance,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20080831/28c64d26/attachment.htm 

More information about the rabbitmq-discuss mailing list