[rabbitmq-discuss] Can't send payloads above 80kB to a RabbitMQ server ?

Maxime Montinet maxime.montinet at gmail.com
Sat Apr 12 04:13:47 BST 2014


I'm trying to send base64 encoded chunks of data through a RabbitMQ server, 
from a Python client.

It goes perfectly fine for payloads in the 1 to ~80kB range, but anything 
above that and I get a connection reset, with an error saying Resource 
temporarily unavailable.

There are absolutely no errors in the server log when this happens.

I have tried this with Python clients, using both pika and rabbitpy, and 
also using different versions of rabbitmq-server (2.8.4 on a Debian host, 
and 3.2.4 on an OSX 10.9 host), the error and its circumstances are the 
same. There was no custom configuration whatsoever done on the test servers.

Here's a link to the script I used for my tests, host/usernames blanked out 
: http://pastebin.com/xWEFeM2K . As you can see, fairly simple test setup, 
and we can see the error appearing at approx. 80kB. All the data that's 
send to the broker is sane (Just a bunch of base64-encoded random junk).

I have also tried to simply reconnect to the broker when this happens, and 
trying again, but as expected my publication is always rejected.

As I understood it, there wasn't really any limit on the size of the 
messages a rabbitmq broker was capable of handling, am I in the wrong here 
? Does anyone know what I can do to sort this out ?

I can provide information as needed, just ask :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140411/98057b1a/attachment.html>

More information about the rabbitmq-discuss mailing list