[rabbitmq-discuss] Invalid bytecode when joining Linux node to Windows cluster

Sjøen, David A. david.sjoen at westcon.no
Thu Nov 14 13:51:09 GMT 2013


I've recently been trying to join a Linux node to a cluster consisting of Windows nodes. The Windows cluster was auto-configured using rabbitmq.config. For some reason, the Linux nodes never joined the cluster.

The first suspect was that I was running different versions of Erlang and RabbitMQ on the nodes, so I made sure everyone was running RabbitMQ 3.1.5 and Erlang R16B02, to no avail.

I then tried to set up a test cluster with one Windows 7 VM and one openSUSE 12.3 VM, without auto-configureing the cluster. When I now try to join the Linux node to the cluster, I get the following:

rabbitmqctl join_cluster --ram rabbit at ROSC21
Clustering node rabbit at pdsp with rabbit at ROSC21 ...
Error: {incompatible_bytecode,"Incompatible Erlang bytecode found on nodes"}

I can't seem to get past this. I even tried recompiling the Erlang RPM with --disable-hipe as a shot in the dark, but no luck.

Is having a cluster of Linux and Windows nodes supposed to be possible at all?

Thanks in advance for any help,

David A. Sjøen
Senior Engineer (Software Development)
Westcon Power & Automation AS

More information about the rabbitmq-discuss mailing list