[rabbitmq-discuss] Configuring SSL when connection is to a load balancer

Sean Whyte sw at swhyte.net
Thu Aug 15 03:27:52 BST 2013

The RabbitMQ logs showed no information during SSL. Unfortunately, I 
don't control the load balancer and they were sure it was configured 
properly, so I had to eliminate every other possibility.

Long story short, it was the load balancer. Got somebody to reconfigure 
it and now it works.

On 8/13/2013 2:04 AM, Michael Klishin wrote:
> Sean Whyte:
>> When the code gets to 'factory.newConnection()', it always times out. With the same code, if I change the port to 80 (and remove the SSL specific stuff), it works fine. I have tried all the various useSslProtocol methods with their different parameters, but always the same timeout result. Not sure what I'm missing.
> It may time out because nothing gets forwarded, take a look at your load balancer logs. Inspecting RabbitMQ
> logs should reveal if there are any AMQP 0-9-1 connection negotiation issues. Please post
> them here if you see any.
> --
> MK
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130814/026a1948/attachment.htm>

More information about the rabbitmq-discuss mailing list