[rabbitmq-discuss] rabbitmq 3.1.4 upgrade lost cluster config

Morty morty+rabbitmq at frakir.org
Tue Aug 13 22:20:25 BST 2013

I had three rabbitmq 3.1.3 two-node (both disc) clusters.  The cluster
config was configured using the configuration file.  They were working

Then I upgraded to 3.1.4.  I did it by following the "whole cluster"
rules from http://www.rabbitmq.com/clustering.html#upgrading -- took
down the cluster, upgraded the last node, started the upgrade node,
tested the upgrade node, and then upgraded + started the other node.

This worked just fine on the first cluster (development/test) I tried
it on.  On the second cluster, the other node is refusing to start.
Error message: "Node rabbit at rabbitmq91 thinks it's clustered with node
rabbit at rabbitmq92, but rabbit at rabbitmq92 disagrees".  Sure enough,
"rabbitmqctl cluster_status" on rabbitmq92 only lists itself.  This
was working fine before.  I tested by adding vhosts on each node and
verified that they showed up on the other node.

Any idea what's up?

I'm sure I could get this working by deleting the mnesia DB on the
second node, starting it as standalone, and manually joining it to the
cluster.  But that will lose any node-specific data.  So I'd rather
not do that.

- Morty

More information about the rabbitmq-discuss mailing list