[rabbitmq-discuss] no next heap size found after crash

Gilles Danycan gdanycan at slip-software.com
Thu Apr 25 07:04:05 BST 2013

Hi All, 

Unfortunately i have a new problem now :( 
i'm still on : RabbitMQ, Erlang R14A 
server: 1To disk , 48Go ram , bi xeon 16 cores 

the server just reboot without reason apparently but the rabbitmq is not able to start after the reboot... 
i have the message : 

Crash dump was written to: erl_crash.dump 
no next heap size found: -2063447786, offset 0 
Crash dump was written to: erl_crash.dump 
eheap_alloc: Cannot allocate 18446744065900154288 bytes of memory (of type "heap"). 

i tried to change the vm_memory_high_watermark in the config file but the second message appears. 

unforutnatly the partition of the rabbit is : 
/dev/sda2 910G 864G 1006M 100% /var 

i don't understand because we have only 5millions of messages in all queues... the last night i deleted some messages (more than 1millions) but the space disk available didn't change... 
is there some problem with erlang or indexes? we consume and requeue messages and when we don't requeue message the space disk used is still the same. 

it a rabbitmq server used in production, 
how can we start the rabbit now? 

Gilles Danycan 

IT Director - Slip Software 
Calle Guitard, 43, p3 
08034 Barcelona 
Tel : +34 932 055 731 
Fax : +34 933 301 973 
Skype: gilles_beverly 
Web: www.slip-software.com 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130425/1d5ca3b9/attachment.htm>

More information about the rabbitmq-discuss mailing list