[rabbitmq-discuss] basicPublish() Hangs on the Upstream Node in a Federation

Chris Judkins-Fisher squall1386 at hotmail.com
Tue Jul 31 23:49:56 BST 2012

Hi Emile,

I can see the appropriate exchange and queue when list_exchanges or list_queues. Also, this exact code works on rabbit1, and also on my own computer.

The only line logged in rabbit at rabbit2.log when I run that code is "accepting AMQP connection". Is there a way to configure the broker to log any more information?

I should also say that, since sending this message, I've recreated the VM and reinstalled everything without activating the federation plugin or anything, and I'm still getting the same problem. I'm installing rabbitmq on CentOS 5.7, and I have to compile Erlang source because of the problem explained at http://stackoverflow.com/questions/5463503/rabbitmq-install-issue-on-centos-5-5. Everything appears to work with the manual compile, but I'm wondering if this bug has something to do with the Erlang version I'm using. It doesn't seem likely, since I did basically the same setup on rabbit1 and it worked, but it's the only thing I can think of at this point.


> Date: Mon, 30 Jul 2012 12:00:20 +0100
> From: emile at rabbitmq.com
> To: rabbitmq-discuss at lists.rabbitmq.com
> CC: squall1386 at hotmail.com
> Subject: Re: [rabbitmq-discuss] basicPublish() Hangs on the Upstream Node in a Federation
> Hi Chris,
> On 26/07/12 19:59, Chris Judkins-Fisher wrote:
> > are also automatically created on rabbit2. However, if I try to publish
> > to an exchange from rabbit2, the code appears to hang and the message is
> > never delivered. This happens whether I'm publishing to the upstream
> From your description further on it sounds like the channel close
> immediately following the publish is failing. Is it possible that you
> are publishing to a non-existent exchange (testexchange)? What does the
> broker logfile say? The solution in this case is to make sure that the
> exchange you publish to exists.
> -Emile
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120731/30ad3a1e/attachment-0001.htm>

More information about the rabbitmq-discuss mailing list