[rabbitmq-discuss] rabbitmqctl stop_app start_app loses all messages

Farshad Meshkinpour fmeshkinpour at fonality.com
Sat Jul 21 02:26:46 BST 2012

I have a two node cluster (RMQ 2.8.2 Erlang R14B03) and testing HA for
production release. Both nodes configured as disc in the cluster. I have
several mirrored queues.  All queues are durable and auto delete off.
 Messages are posted with delivery_mode 2 (persistent).  I publish some
messages (less than 100).  I see all my messages in the queues via the
management GUI.

I run rabbitmqctl stop_app on node1.
The  /var/lib/rabbitmq/mnesia/rabbit at rmq1-test/msg_store_persistent before
stop_app is:
-rw-r--r-- 1 rabbitmq rabbitmq 472724 Jul 20 15:09 0.rdq

After the stop_app:
-rw-r--r-- 1 rabbitmq rabbitmq 472724 Jul 20 15:09 0.rdq
-rw-r--r-- 1 rabbitmq rabbitmq   1664 Jul 20 15:15 clean.dot
-rw-r--r-- 1 rabbitmq rabbitmq    474 Jul 20 15:15 file_summary.ets
-rw-r--r-- 1 rabbitmq rabbitmq  48953 Jul 20 15:15 msg_store_index.ets

Then I run rabbitmqctl start_app (without publishing any message) and
msg_store_persistent is cleared.

-rw-r--r-- 1 rabbitmq rabbitmq 0 Jul 20 15:16 0.rdq

After I do app_stop&app_start on node1  all my queues become unsynchronised
(without publishing any new msgs).  The management interfaces says all msgs
are only on node2 only.
If I go through the same sequence of app_stop&app_start on node2, then all
msgs are lost!

Note, I get the same result if use /etc/init.d/rabbitmq-server start/stop.

Could someone let me know what might be wrong with my configuration or what
I am doing wrong?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120720/c9759d0a/attachment.htm>

More information about the rabbitmq-discuss mailing list