[rabbitmq-discuss] Plz give me help about EPMD: Non-local peer connected

何斌 hebin7611 at hotmail.com
Fri Jul 13 11:29:02 BST 2012

Hi all,

Yes, I guess the problem is caused by erlang. It does not support multi interface?

I hacked epmd with following codes:

          s->local_peer =
              (((((unsigned) ntohl(si.sin_addr.s_addr)) & 0xFF000000U) == 0x7F000000U) ||
              (getsockname(s->fd,(struct sockaddr*) &di,&st) ? EPMD_FALSE : (((((unsigned) ntohl(di.sin_addr.s_addr)) & 0xFF000000U) == 0x7F000000U) || si.sin_addr.s_addr == di.sin_addr.s_addr)));

But I am not sure it's secure.

From: tim at rabbitmq.com
Date: Fri, 13 Jul 2012 09:46:18 +0100
To: rabbitmq-discuss at lists.rabbitmq.com
Subject: Re: [rabbitmq-discuss] Plz give me help about EPMD: Non-local peer	connected

On 13 Jul 2012, at 08:17, 何斌 wrote:Sorry, I tried I tried "erl -sname rabbit" with a hacked version.
With the official release version of epmd, I got error.

You should really take this issue to the erlang-questions mailing list, as it is not rabbit specific and sounds like something that ought to be documented for CentOS users in general. My own networking configuration on CentOS did not work OOTB and I had to add the (single) hostname entry on a separate line to the localhost.localdomain setup, as well as editing the sysconfig/net* entry, before I got distributed Erlang nodes to start up. 
rabbitmq-discuss mailing list
rabbitmq-discuss at lists.rabbitmq.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120713/be955c97/attachment.htm>

More information about the rabbitmq-discuss mailing list