[rabbitmq-discuss] Cluster setup : rabbitmq server stops responding to rabbitmqctl commands

Francesco Mazzoli francesco at rabbitmq.com
Thu Jul 12 14:26:15 BST 2012

At Thu, 12 Jul 2012 12:57:31 +0000,
sanjiv kumar jha wrote:
> I tried replicating this using rabbitmq-server 2.8.4 version, but noticed a
> different kind of issue. In current setup, 'rabbitmqctl list_queues' is
> working whereas 'rabbitmqctl status' is not responding. Even 'rabbitmqctl wait
> /var/run/rabbitmq/pid' does not respond, keeps waiting.

If I understand correctly the log you posted is on node-A *after* you brought
down node-B, right? In any case, things look OK. Could you attach the logs
in their entirety (both node A and B)?

The best thing would be for you to post a script that replicates what you're
trying to do and reproduces the behaviour you're seeing. Needless to say I have
tried to replicate your problem to no avail.

Francesco * Often in error, never in doubt

More information about the rabbitmq-discuss mailing list