[rabbitmq-discuss] Authentication Backend HTTP

Francesco Mazzoli francesco at rabbitmq.com
Mon Jul 2 16:16:17 BST 2012

Hi Eleanor,

At Mon, 2 Jul 2012 07:46:42 -0700 (PDT),
eleanor  wrote:
> Hi, sorry for not being clearer. Of course I run 'make' in the http plugin
> directory. I can prove it:
> # pwd
> ./rabbitmq-public-umbrella/rabbitmq-auth-backend-http
> # make
> make: Nothing to be done for `dist'.
> To provide more info. The plugins directory in rabbitmq-server has the
> following entries:
> # pwd
> ./rabbitmq-public-umbrella/rabbitmq-server
> # ls -l plugins/
> total 0
> lrwxrwxrwx 1 eleanor eleanor 32 Jul  1 19:22 rabbitmq-auth-backend-http ->
> ../../rabbitmq-auth-backend-http
> lrwxrwxrwx 1 eleanor eleanor 28 Jul  1 18:47 rabbitmq-erlang-client ->
> ../../rabbitmq-erlang-client

That looks fine. What does `./scripts/rabbitmq-plugins list' say?

What I suspect you're doing, given your previous messages, is running
the system-wide utilities instead of the ones in the local broker:

> This should be fine, since the rabbitmq-auth-backend-http is enabled. The
> problem happens with the enable command:
>      # rabbitmq-plugins enable rabbitmq_auth_backend_http
>      Error: The following plugins could not be found:
> rabbitmq_auth_backend_http

that `rabbitmq-plugins' as root looks does not look good. Make sure
that you're running the executables in the `rabbitmq-server/scripts'
folder, inside `rabbitmq-public-umbrella'.

> And I have to run the "make run" in rabbitmq-server as root to run the
> server. If I run it as normal user I get the following error - maybe this is
> connected to http plugin not working:
> [...]
> (rabbit at rabbit1)1> {"init terminating in
> do_boot",{{nocatch,{error,{cannot_log_to_file,"/tmp/rabbit at rabbit1.log",{error,eacces}}}},[{init,start_it,1},{init,start_em,1}]}}
> init terminating in do_boot ()
> make: *** [run] Error 1

That is probably happening because the user does not have permissions
on the existing log file, or maybe /tmp itself (although that seems
unlikely). Clear the existing files and make sure that /tmp is
writable by the user you want to run rabbitmq from.

Francesco * Often in error, never in doubt

More information about the rabbitmq-discuss mailing list