[rabbitmq-discuss] Authentication Backend HTTP

eleanor evangeline.eleanor at gmail.com
Mon Jul 2 15:46:42 BST 2012

Hi, sorry for not being clearer. Of course I run 'make' in the http plugin
directory. I can prove it:
# pwd

# make
make: Nothing to be done for `dist'.

To provide more info. The plugins directory in rabbitmq-server has the
following entries:
# pwd

# ls -l plugins/
total 0
lrwxrwxrwx 1 eleanor eleanor 32 Jul  1 19:22 rabbitmq-auth-backend-http ->
lrwxrwxrwx 1 eleanor eleanor 28 Jul  1 18:47 rabbitmq-erlang-client ->

And I have to run the "make run" in rabbitmq-server as root to run the
server. If I run it as normal user I get the following error - maybe this is
connected to http plugin not working:
$ make run
RABBITMQ_PLUGINS_EXPAND_DIR="/tmp/rabbitmq-rabbit-plugins-scratch" \
kernel-poll not supported; "K" parameter ignored
Erlang R13B04 (erts-5.7.5) [source] [64-bit] [rq:1] [async-threads:30]

Eshell V5.7.5  (abort with ^G)
(rabbit at rabbit1)1> {"init terminating in
do_boot",{{nocatch,{error,{cannot_log_to_file,"/tmp/rabbit at rabbit1.log",{error,eacces}}}},[{init,start_it,1},{init,start_em,1}]}}
init terminating in do_boot ()
make: *** [run] Error 1

Any ideas?

View this message in context: http://rabbitmq.1065348.n5.nabble.com/Authentication-Backend-HTTP-tp20476p20509.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list