[rabbitmq-discuss] RabbitMQ Fails to start - Erlang machine stopped instantly (distribution name conflict?)

Tim Watson tim at rabbitmq.com
Tue Aug 28 17:58:04 BST 2012


On 28 Aug 2012, at 17:18, Joe Klug wrote:

> I had originally installed RabbitMQ 2.8.4 with Erlang Win64 R15B01 on my Windows 7 laptop.  Everything worked just fine.  I later uninstalled both RabbitMQ and Erlang, and then installed 2.8.6 with Erlang Win32 R15B01 and get these 2 errors every time I start the server:
> Error 1:
> RabbitMQ: Erlang machine stopped instantly (distribution name conflict?). The service is not restarted as OnFail is set to ignore.
> Error 2:
> The RabbitMQ service terminated with the following error:
> The process terminated unexpectedly.
> I’ve tried everything I can find on this discussion list and anywhere else Google can reach.  I’ve uninstalled, reinstalled, retried the Win64 verions of Erlang, tried cleaning out the registry, set environment variables, all to no avail.
> Any suggestions?

Can you run 'erl -sname rabbit' in the console (cmd) for starters?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120828/5e563ff9/attachment.htm>

More information about the rabbitmq-discuss mailing list