[rabbitmq-discuss] .NET ssl_upgrade_failure

Mark Ward ward.mark at gmail.com
Thu Aug 2 15:50:21 BST 2012


I will see how to use stunnel to trouble shoot the situation. I have never 
used it.

If I run the .net client with a client certificate the .net client errors 
out the same.  It gives me the exception "None of the specified endpoints 
were reachable".  Although, the server is a little different.  The server 
does not error out and perform a dump.  It gives the following error that 
the connection_closed_abruptly.  This is the same error regardless of how I 
change the verify and fail_if_no_peer_cert settings in my server's 
configuration.  The Java client continues to connect appropriately. 

=INFO REPORT==== 2-Aug-2012::09:45:46 ===
accepting AMQP connection <0.613.0> ([FE80::9CF9:E6C8:AAA2:E95E]:60317 -> 

=WARNING REPORT==== 2-Aug-2012::09:45:46 ===
closing AMQP connection <0.613.0> ([FE80::9CF9:E6C8:AAA2:E95E]:60317 -> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120802/5bd3713b/attachment.htm>

More information about the rabbitmq-discuss mailing list