[rabbitmq-discuss] STOMP Plugin 2.4.0 Issue

Alexander Goldstone alex at kinishi.com
Wed Mar 30 17:32:18 BST 2011

Hi Steve,

Thank you for taking the time to look at this for me.

I started with a regular 64-Bit Ubuntu 10.10 running on an Amazon EC2 micro instance.

I changed the hostname of the instance and then ran:

		sudo apt-get update && sudo apt-get upgrade -y

I then copied and pasted the rabbitmq-user-data.sh script documented at:


Once the latest (2.4.0) rabbitmq was installed using that script I installed the plugins:

cd /usr/lib/rabbitmq/lib/rabbitmq_server-2.4.0/plugins/
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/mochiweb-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/webmachine-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/amqp_client-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/rabbitmq-mochiweb-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/rabbitmq-management-agent-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/rabbitmq-management-2.4.0.ez
sudo wget http://www.rabbitmq.com/releases/plugins/v2.4.0/rabbit_stomp-2.4.0.ez
sudo /etc/init.d/rabbitmq-server restart

I did not manually install erlang itself but I can see that the version I have ended up with after the above is R13B03.

I didn't do anything else so I can't see what I could have done differently. This same process worked for the previous version of rabbitmq for which I was able to telnet and use the STOMP plugin fine.

I just removed all plugins except amqp_client-2.4.0.ez and rabbit_stomp-2.4.0.ez and restarted rabbitmq as this was the only difference I could see between your tests and mine (other than the operating system and erlang version).

Removing the other plugins and restarting rabbitmq had no impact on this issue so I would really appreciate you repeating your test on an Ubuntu client as that would seem to be the only difference between your tests and mine.

If there is anything else I should try and/or any other details I can provide that would be useful then please let me know.



On 30 Mar 2011, at 16:41, Steve Powell wrote:

> Hi Alexander,
> I'm able to run happily on the (in-house) 'best-so-far' version of rabbitmq-stomp:
> ---------------------------------------------------8<----cut-here-----------
> 15:29:30 :> telnet localhost 61613
> Trying ::1...
> Connected to localhost.
> Escape character is '^]'.
> login:guest
> passcode:guest
> ^@
> session:session-A/W+DDK95d4+ZZehxZHkZQ==
> heartbeat:0,0
> version:1.0
> ^@
> Connection closed by foreign host.
> 15:30:31 :>
> ---------------------------------------------------8<----cut-here-----------
> but this is, I admit, a development version, so the next thing I tried is to download my own fresh RabbitMQ 2.4.0....
> (I'm on Mac, so I used macports to install rabbitmq-server (@2.4.0) and put amqp-client-2.4.0.ez and rabbit-somp-2.4.0.ez in the plugins directory, ran 
> 'sudo rabbitmq-server' and repeated the above experiment.)
> And it worked identically for me.  So, this is probably a set-up issue for you.  Can you provide the installation steps you went through, please? Oh, and the versions of Erlang and so on are very useful, too, thanks.
> Here is my 'rabbitmqctl status' output for comparison:
> [{pid,73212},
> {running_applications,[{amqp_client,"RabbitMQ AMQP Client","2.4.0"},
>                        {rabbit_stomp,"Embedded Rabbit Stomp Adapter","2.4.0"},
>                        {rabbit,"RabbitMQ","2.4.0"},
>                        {mnesia,"MNESIA  CXC 138 12","4.4.16"},
>                        {os_mon,"CPO  CXC 138 46","2.2.5"},
>                        {sasl,"SASL  CXC 138 11",""},
>                        {stdlib,"ERTS  CXC 138 10","1.17.2"},
>                        {kernel,"ERTS  CXC 138 10","2.14.2"}]},
> {nodes,[{disc,['rabbit at spowell-desktop']}]},
> {running_nodes,['rabbit at spowell-desktop']}]
> I appear to be running a more modern version of Erlang and its friends here, but the next step would be for me to try this on an Ubuntu client (which I can probably do, but it will take me a little time to set one up.)
> Please just come back here if you need me to try that.
> Steve Powell
> On 30 Mar 2011, at 09:44, Alexander Goldstone wrote:
>> Are there any known issues with the STOMP plugin for RabbitMQ 2.4.0 ?
>> I am used to connecting to the STOMP plugin via Telnet and issuing CONNECT, SEND and SUBSCRIBE frames by hand. For previous versions of RabbitMQ this has all worked fine. Now, for a clean install of RabbitMQ 2.4.0 on Ubuntu 10.10, I am not even able to successfully CONNECT using something like:
>> 		login:guest
>> 		passcode:guest
>> 		^@
>> I send a line-break after the passcode and then send another line-break but the server closes the connection before I am able to send the NULL frame terminator. The server does not output any error messages.
>> Similarly, if I follow the "Testing the adapter" example at http://www.rabbitmq.com/stomp.html then the server closes the connection after the second time I send "dummy" but it does not output an error message.
>> The RabbitMQ Management Plugin shows the STOMP plugin is listening on port 61613.
>> The Erlang version provided as standard for Ubuntu 10.10 seems to be R13B03 and th output from "rabbitmqctl status" looks like this:
>> [{pid,28410},
>> {running_applications,
>>    [{rabbit_management,"RabbitMQ Management Console","2.4.0"},
>>     {webmachine,"webmachine","1.7.0"},
>>     {rabbit_management_agent,"RabbitMQ Management Agent","2.4.0"},
>>     {amqp_client,"RabbitMQ AMQP Client","2.4.0"},
>>     {rabbit_mochiweb,"RabbitMQ Mochiweb Embedding","2.4.0"},
>>     {mochiweb,"MochiMedia Web Server","1.3"},
>>     {inets,"INETS  CXC 138 49","5.2"},
>>     {rabbit_stomp,"Embedded Rabbit Stomp Adapter","2.4.0"},
>>     {rabbit,"RabbitMQ","2.4.0"},
>>     {mnesia,"MNESIA  CXC 138 12","4.4.12"},
>>     {os_mon,"CPO  CXC 138 46","2.2.4"},
>>     {sasl,"SASL  CXC 138 11","2.1.8"},
>>     {stdlib,"ERTS  CXC 138 10","1.16.4"},
>>     {kernel,"ERTS  CXC 138 10","2.13.4"}]},
>> {nodes,[{disc,[rabbit at tatooine]}]},
>> {running_nodes,[rabbit at tatooine]}]
>> ...done.
>> I'm assuming this isn't a problem for everyone using the STOMP plugin otherwise someone would have mentioned it by now so if I can provide any further information to help work out what is wrong on my setup then please let me know.
>> Thanks,
>> Alex
>> _______________________________________________
>> rabbitmq-discuss mailing list
>> rabbitmq-discuss at lists.rabbitmq.com
>> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list