[rabbitmq-discuss] Fwd: socket error while using rabbitmq and a NAT (Network address translation)

Emile Joubert emile at rabbitmq.com
Wed Mar 2 14:21:55 GMT 2011


On 02/03/11 13:25, mysurf mail wrote:
> 1. multicast 1.7.0.
> Ahh.. I was looking for the multicast of 1.7.0. we only kept the (rabbit
> main jar).
> Ok, I ran it on the computer with the bad 2.3.1. communication and it
> ran it without a problem.
> seemed fine. I added the output (in the 1.txt file ).
> So, This computer runs multicast 1.7.0 and not 2.3.1. a riddle.

You previously tried MulticastMain from version 2.3.1 with and without 
the tracer and you saw failures without the tracer. Is this correct?

Can you try running MulticastMain from version 1.7.0 with and without 
the tracer as well? From your description it doesn't sound like you have 
replicated the test in exactly the same way. You will need to use the 
tracer from the 1.7.0 release for this test.

Do you have any way of repeating this test with the client and server on 
the same LAN or on the same host, in order to eliminate the network as a 
cause of the problem? I'm assuming that all your tests are still 
traversing the NAT infrastructure.

Another option is to inspect a network traffic dump. We will need the 
binary capture file produced by wireshark or tcpdump to collect all 
traffic on the port you use for AMQP (1434 in your case) on the client 
and on the broker. Please don't send large binaries to the mailing list 
though. Rather place it somewhere where it can be retrieved from.

> 3. 1.7.0. to 2.3.1. -
> We decided on an emergency solution for the meanwhile - we run rabbitmq
> 2.3.1 server with 1.7.0. jars at the clients.
> so far it seems ok. Are we expecting major problems?

It is impossible to say without understanding the cause.


More information about the rabbitmq-discuss mailing list