[rabbitmq-discuss] Fwd: socket error while using rabbitmq and a NAT (Network address translation)

Emile Joubert emile at rabbitmq.com
Wed Mar 2 12:55:25 GMT 2011

On 02/03/11 12:38, mysurf mail wrote:
> Hi,
> I ran the multicast main . from the computer with the good connection it
> seemed to work.
> from the computer with the bad connection - it seemed to not work.
> I was seconds away from taking this to the IT , but then I remembered
> that both computes run the RabbitMQ client 1.7.0 successfully .
> Maybe you can tell me what changed in the implementation of the 2.3.1 or
> the erlang??

The release notes should contain this information. You can get these 
from the rabbitmq-announce mailing list archives:


If version 1.7.0 worked, can you try to repeat the MulticastMain test, 
but using MulticastMain and client from the 1.7.0 release? You'll find 
it here:


> I am adding the output file for the multicast. it has outputs from both
> computers.

You have left out the full command issued on GoodComputer. Can you 
please supply this?

You should be aware that 1434 (UDP) is a registered port for MS SQL 
Server. Is there any reason why you are not using the default AMQP port 
(5672)? Can you try using port 5672?



More information about the rabbitmq-discuss mailing list