[rabbitmq-discuss] Management plugin throwing "cannot read property" errors

Jason J. W. Williams jasonjwwilliams at gmail.com
Fri Jun 10 18:22:42 BST 2011

Hey Simon,

Actually, I found an error message in rabbit.log that seems related to
that: https://gist.github.com/1019290

Any ideas? It appears to happen some period of time after several
vhost/user/permission creations via the REST API.


On Fri, Jun 10, 2011 at 3:12 AM, Simon MacMullen <simon at rabbitmq.com> wrote:

> On 10/06/11 02:15, Jason J. W. Williams wrote:
>> Hi All,
>> On a new server running RMQ 2.4.1 with the management, I've noticed a
>> behavior where after about 30 minutes of runtime the WebUI for the
>> management plugin starts showing this error at the bottom of the page:
>> "TypeError: Cannot read property 'messages_ready' of undefined"
>> You can navigate the UI but the message counters are "?" in addition to
>> the error message. The _log, _err, and .log files show no errors. Any
>> idea what might be causing this? Thank you in advance.
> Hi Jason. What you're seeing is consistent with the management statistics
> database going away.
> I can see this happening in two ways - either you're running a cluster and
> the node hosting the db went down (one day we'll have failover for this, but
> not yet), or it crashed - but in that case I would expect the supervisor to
> restart it.
> So - are you running a cluster? If not, can you send me the logs somehow?
> Cheers, Simon
> --
> Simon MacMullen
> RabbitMQ, VMware
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110610/700938ec/attachment-0001.htm>

More information about the rabbitmq-discuss mailing list