[rabbitmq-discuss] client libraries compatibility
matthias at rabbitmq.com
Wed Jan 26 21:27:54 GMT 2011
Mark Geib wrote:
> We are currently running mostly 1.6.x rabbitmq brokers with 1.6.x
> client libraries, both java and .net.
> You are looking to migrate to the current broker, 2.2.x, but need some
> suggestions on how to handle the client libraries.
> We understand there are issues with 1.6.x clients working with 2.2.x
> brokers, mostly .net. Also we have issues with the 2.2.x client
> libraries working with the old 1.6.x brokers.
> So, can we upgrade the clients to use later libraries that will work
> with both 1.6.0 and 2.2.0 brokers.? Like 1.8.x ??
- any version of any client we have ever released should work with a
broker >= 2.2.0
- clients >= 2.2.0 will only work with brokers >= 2.2.0, except for the
.net client which can speak to older brokers if configured to speak AMQP
I am curious what issues you are referring to regarding the 1.6.x .net
client and 2.2.x brokers.
More information about the rabbitmq-discuss